Virtual Receptionist Doesn't Answer

I setup my Ooma Office and have it configured to as a forwarding number for my google voice account. When I call the ooma office number directly, the virtual receptionist picks up immediately. However, when I call the google voice number (which forwards to the ooma office number), the virtual receptionist never picks up. I tried to change the settings on the google voice account and nothing worked. I couldn’t find any settings in the Ooma office manager settings.

My google voice number is used for all of my business and I really don’t want to change it.

Thanks for any help on this issue.

Is your Google Voice call screening on?

No, call screening is off. Even so, I would expect the VR to pick up. However, the line just keeps ringing until the Google voicemail answers.

Just verified that this is the behavior I experience as well; virtual receptionist doesn’t come on but Google Voice VM.

I did find a workaround. You can create a ring group with only 1 extension in it. Have the extension ring for only 10 seconds and have it roll into Virtual receptionist if not answered. Have your main Ooma office number ring this ring group. Calling the GV (forwarding to your Ooma office number) would get you the virtual receptionist.

Did you also forward the Office to your Google voice number?
That would create an infinite loop and Ooma will block that condition.

I do not have the VR forwarding back to Google Voice. So there shouldn’t be any infinite loop issue.

When calling Ooma office going straight to virtual receptionist, there is no answer tone coming back so Google Voice may not detect that as “answered” so try the workaround that I mentioned.

So I did the recommendation of creating a call group which then forwards to the virtual receptionist. It seems to work. However, now I have two other issues:

  1. The call forwards to an old extension that has since been remapped. Seems like the bug that was reported in the other thread where the forwarding number is permanently used even though it has been remapped. A result when changing the line type (e.g. linx to virtual extension). I tried deleting all the associated extensions and rebooted and the problem persists.

  2. The phone connected to the base port never rings. It actually shows as “Offline” in the Office Manage Extensions window even though there is a dial tone and I am able to make calls out on it.

More help please!!

The problem resolved itself. I believe what did it was changing the phone number mapping, then changing it back.

GV has this feature you can’t disable where if the called party answers too quickly it assumes it’s an answering machine, so it plays this prompt: ‘in case of a fast pickup we ask to let us know this is not a voicemail system so you need to press 1 to accept this call’. There’s an open bug to workaround this problem. Great you found a way to workaround it in the mean time.

I’m having the same exact problem. Creating a ring group does not seem to solve the problem. It goes stright to Google Voicemail. aside from that I don’t see any option within the ring group to ‘rollover’ to virtual receptionist. Under advanced options, there’s an option after x seconds (I set it to 10 as suggested) to forward to an extension. But Virtual receptionist is not shown as an extension and I can’t manually enter its default extension (100).

Also for some reason when I call from my phone, I do get the virtual receptionist (maybe since i’ve called multiple times?) but i can clearly tell that all my customers are going straight to voicemail. I asked a friend to call and they also went to voicemail. Even when I personally get the virt receptionist, it seems to start a second or two seconds into the message.

Is your GV configured correctly? Forward your GV to your cell, get that working right and then switch forward to your Ooma Office.

Yes. My google voice IS configured properly. i’ve used it for the last 5 years to forward to my cell without any issues. i’ve removed the cell from GV numbers for good measure, removed call screening, and i’m still getting this problem. there is definitely something wrong. my customers are going straight to GV Voicemail. Everything in Ooma is set properly. When I call from my own cell, I do usually get through to the virt receptionist. Perhaps, known contacts get routed differently from new callers? The settings within GV are the same though for both contacts and anonymous callers so that shouldn’t be an issue.

when i call from my cell i do get through to the virtual receptionist, but my customers are not getting through. Even when I try, it’s not consistent. And when I do get through, I miss the first second or so of the message. If I redial immediately after a successful attempt, it just rings and sends me back to GV voicemail. So until this is figured out, I’ve just bypassed the virtual receptionist and am forwarding directly to my extension. But that defeats the purpose. There is something wrong here.

If i block my caller id on my smartphone as I have been, i get through to the virtual receptionist (albeit with the problem mentioned before of it starting a couple seconds into the message). When I enable caller id on my smartphone, I go straight to Google Voicemail as all my customers have been. I do not have any groups set up in Google Voice so I don’t understand this at all.

Send an email to Ooma moderator Bobby and he will configure this option for you. There is a bug open to add this feature back to the UI. See https://www.ooma.com/forums/viewtopic.php?f=17&t=16687

Also see https://www.ooma.com/forums/viewtopic.php?f=6&t=16882&start=10

emailed bobby yesterday. waiting for his reply. thanks. i don’t get why Telo has a GV integration, and paying Office customers have to run off to forums to find workarounds. that’s just not right.

As explained in the referenced post above the GV integration on residential does NOT address the way Google handles immediate answer, so there is no difference between Office and residential in that respect.

This problem can now be corrected in the Virtual Receptionist settings screen. 1) Log in to Ooma Office Manager, 2) click on “Manage” at the top of the screen, 3) then click on “Receptionist”, 4) then click “Settings” near the top of the screen where you set your greeting and key press assignments. Finally, 5) check the box next to “Ring for two extra seconds before answer”. This corrects the problem with the immediate answer function of Google Voice and the Ooma Office virtual receptionist.

I guess Google fixed a bug because we received reports this wasn’t working for a while, but perhaps these customers forgot to disable call screening on the Google voice portal.

The ring group work around is not working for me. I am really trying to find a way to setup a remote employee so I was trying Google Voice with an Ooma Telo at the remote location so the Telo can call out using the GV number that way if a client calls that number back they still go to the virtual receptionist. I think it will work if I can get the GV number to actually ring the virtual receptionist…why is this so difficult :slight_smile: