The person you're calling does not accept calls from private

This is very frustrating. Some phone calls I receive now get the above message. They did not have this issue until recently. They are not blocked numbers.
Why is Ooma ow responding this way. :neutral_face:

Go to call blocking preferences in your account and remove the check mark on block anonymous calls.
Or tell the people that are having this problem to configure their phone system to allow sending their caller ID.

I’m not able to find this setting in the web interface.

It’s under Preferences → Call Blocking.

It’s called Block Anonymous Calls.

Are you a Premier subscriber? If not, I doubt you have the feature.

Premiere? I thought Ooma Office only had one level of service. Sorry about that.

Sorry, I totally missed that you were talking about Office. I know almost nothing about Office.

I also found that setting your outgoing caller ID to your toll free number causes this problem. A lot of business must block calls from toll free numbers (probably because they are bogus). Changing it back to my main non toll free number did the trick and prevented this issue.