Testing Ooma Mobile: sip uri invalid for call

This message is about beta testing the Ooma Office mobile app. I have it installed on two mobile phones.

My system has five telephones. I have an extension for each of five employees and and extension for the virtual receptionist and another extension to Ring Everybody which is a group that will ring all five phones.

From one of my mobile phones I just clicked on the extension to Ring Everybody and all the phones rang in the office. So far so good. I then answered that phone.

Then I tried to call again to Ring Everybody using the other mobile phone. This time I was presented with an error message that says sip uri invalid for call: 109

109 is the extension number I am using to ring everybody.

Now when I try to use either mobile phone and click on one of the extensions to call into the office I get the same error message: sip uri invalid for call: 1xx (varied extension numbers)

It looks like I am going to have to restart my mobile phones in hopes that they will be able to call into the office system.