Port Foward CGILUAError

Tech support has not been able to resolve this issue for me yet, and wondered if any other user has seen this and solved it.
My broadband supplier is BrightHouse Cable.
Had been using a setup Modem> Lynx Router> Telo
Problem was reduced voice quality and unable to send fax.
Moved to Modem> Telo> Router and voice improved and can now fax.
But my CCTV DVR can no longer get to the DSN. For that to work I need to Fwd three Ports. It was working when Telo was behind the Router, but one Telo was moved, it blocks the traffic by default.
I can access the Telo home page, and all the pages except the advanced page. It throws the CGILUAError listing below.
First I was alerted to “… some aggressive anti virus software …” as the cause.
Tried 5 different client machines, using three different operating systems, and four browsers. All throw the same error.
Interestingly, when I first booted the last replacement Telo, I was able to reach the advanced page, and started to input the port forward rules, but it threw an error about the network needing to be connected prior to port forwarding. As soon as the Internet and Ooma Network came up, the Advanced page threw the same error.
Today I loaded a Linux Distro booting from a DVD with only FIreFox running. Still no joy, and same exact error.

I am told the third replacement Telo is on its way, just in case it is a box issue.

Any idea on how to overcome the issue and forward those ports?

Thanks,
Mark

CGILUAError:
utilityAdvanced.lua:612: attempt to index local ‘s’ (a number value)
stack traceback:
utilityAdvanced.lua:612: in function ‘trim’
advanced.lp:100: in function ‘prog’
/usr/share/lua/cgilua/lp.lua:132: in function ‘include’
/usr/share/lua/cgilua.lua:282: in function
(tail call): ?
(tail call): ?
stack traceback:
/usr/share/lua/cgilua.lua:161: in function ‘err’
/usr/share/lua/coxpcall.lua:24: in function
(tail call): ?
(tail call): ?
/usr/share/lua/cgilua.lua:169: in function ‘pcall’
/usr/share/lua/cgilua.lua:630: in function ‘main’
/usr/share/lua/wsapi/sapi.lua:53: in function
(tail call): ?

There’s an open bug on this. We’ve had problems reproducing the issue. Thank you for this additional information.

Tried a new Telo Office unit this morning no joy
Set up is Cable Modem (Motorola Surfboard SB6141 192.168.100.1) → Telo 172.27.35.1 ->PC (172.27.35.24 hooked directly to Telo)
When the Telo first came up, the advanced page (Port Forwarding) was accessible.
As soon as the Telo connected to the internet, the advanced page could no longer be accessed.
Any suggestions?

Update:
Tried to access the Advanced tap today and it worked! The CGILUAError is no more!
Still need some help.
My Setup remains a BrightHouse Cable Modem, then the Ooma Telo IP 172.27.35.1, then my Cisco Valet Router 172.27.35.141.
On the Private LAN I have a CCTV DVR at 192.168.1.108 that I need to port forward thru to the internet.
When I tried to add the rules for the DVR’s private IP, the Telo errors with “ports must be the same subnet”
Can you tell me what I am missing?

In the router forward the port to the DVR’s IP address 192.168.1.108.
In the Telo forward the port to the router’s IP address 172.27.35.141.

Unfortunately those are the settings I used, but still no joy.