Ooma tell does not work behind SBG6580

I upgraded to a combo modem recently. No matter what I do OOMA router keeps on blinking with the red flower.
Before that OOMA worked for 5 years as router behind my old modem.

I tried dynamic IP, static IP, port forwarding and the last one - DMZ zone.
I can see internet when I use the HOME port in either of the configurations.
Since DMZ does not help I am completely puzzled.
Setup page of the device states that it can not connect to OOMA network. I can see on my router
setup page that the device gets IPs for both MACs that it has.

Try DMZ again. Give your Ooma reserved DHCP IP and then DMZ that IP. Power cycle both. Turn on modem first then Ooma.

Well without diving to much into this, all gateway devices are terrible especially for wireless connections. Put the gateway in full Bridge mode and connect up you working router and go.

This is what I found after couple evenings and coupe hours with OOMA and Arris support.
Not much help from either.
What I found after experiments is that for this particular problem:

  • DMZ does not work
  • Port forwarding does not work
    → LOW level of firewall works!!!

Arris support mentioned SIP ALG problems today so I started looking for more info:
http://www.dslreports.com/forum/r28676066-Ooma-uses-SIP-:

Every ITSP that I have ever used has recommended disabling any SIP ALG in consumer class NAT/routers.
OnSIP staff told me that unless I have business-class gear from Cisco or Juniper don’t use any ALG. Let their NAT traversal solution handle the issue.

http://www.voip-info.org/wiki/view/Routers+SIP+ALG:

Many of today’s commercial routers implement SIP ALG (Application-level gateway), coming with this feature enabled by default. While ALG could help in solving NAT related problems, the fact is that many routers’ ALG implementations are wrong and break SIP.

Darveter >>> Moto info below might be old because SIP ALG shows as if it is possible to disable now.
Will try it tonight. I hope I do not have to disable NAT and go to bridge mode. What
is the point of having combined device if I disable the router in it.>>>

Motorola:

Models: SBG6580 (SurfBoard Extreme Wireless Cable Modem Gateway)
No Registeration possible behind NAT as the device changes Call-ID and causes the responses to be discarded by SIP clients/ATAs

No Solution at this time (SIP ALG, called SIP Pass Through, can not be disabled) .
Must disable NAT and put the device in bridge mode. (See this guide)

SIP ALG removal did not help much.

Still medium firewall kills the OOMA connection and port forwarding does not help either.

The only working config so far - low level firewall, with Port scan detection, Partial IP packets and IP flood checked.

How can I get onto the 8* line of the firmware?

Can it be that list of the ports is wrong?

Take a look here…your modem might be set wrong.

http://www.motorolasbg6580guide.com/setting-parental-control-and-firewall/