Nothing working as it should

So, I have had ooma office at my business for several months now. It started out OK with some minor hiccups, nothing major. At the time that I made the transition to ooma it was the slower time of year for my business so the call traffic was less. Now it is my busy season and I am receiving a lot more calls I am having constant issues.

My setup: I have 7 lines in total and 2 base stations. All lines are on a ring group and the 1st option on the auto attendant is to “speak with the first representative” which rings all the phones on the ring group.
This is the best way to manage my phone traffic for the type of business that I do.

The issues:

  1. lots of echoing on my end, especially if there is more than one user on the phone at once.
  2. if I am talking and another call comes in then with every ring my audio cuts out and I can’t hear what the person on the other end is saying. Sometimes it effects them hearing me as well.
  3. When making outgoing calls, sometimes it starts ringing then goes to a dial tone and the call drops. Other times it takes 10-20 secs to connect the call.
  4. often times when I go to pick up a call it drops. My customers have to call back
  5. the ooma office app has terrible delay and audio quality when using on my android phone. Even when at home on a separate network from my business. Network speed at home is 150/30
  6. More often recently the link Devices are getting lost from the base stations I have to reboot the bases to get them to reconnect.

Basically, in general, the system is unreliable and not usable.

I have been working with support to no avail. I have tried QOS, Port forwarding and now support would like for me to connect the base stations in from of my router directly to the modem but I am waiting for them to send me a schematic to do this as the one they sent me only shows a setup with 1 base station.
My Internet speed is 30/2

So my question to other users is: can this system function properly and reliably? Is there any hope? Is it just my particular setup with the ring group and maybe this system won’t work for what my specific needs are? I don’t know where to go. Ive invested in equipment and phones and nothing works. I don’t have hours to spend troubleshooting with support. I have a business to run. Does anyone have any suggestions or words of encouragement? Or is it time to throw in the towel with ooma?
Thanks

  1. Does this only happen when calling certain numbers?
  2. To suppress the call waiting beep either dial *70 before placing a call or disable it for your extension in the Devices tab.
  3. Please provide some call examples (date/time/zone).
  4. same as 3).
  5. Are you using v2.0? More improvements are in the works.
  6. Please report back with new occurrences.

Thank you Tom for taking the time to respond.

  1. Does this only happen when calling certain numbers? - No, there doesn’t seem to be any rhyme or reason to it except that it seems to happen more so when multiple lines are in use at the same time or if you are on a call for an extended period of time- like 5 mins or more.
  2. To suppress the call waiting beep either dial *70 before placing a call or disable it for your extension in the Devices tab. - thank you, I will try this and see if it fixes the issue.
  3. Please provide some call examples (date/time/zone). - I will private message you a link to a google sheet where I am starting to log all issues
  4. same as 3).
  5. Are you using v2.0? More improvements are in the works. - I am using latest version.
  6. Please report back with new occurrences. - I will

What is the make/model of your modem and router? We have found that with some routers Office doesn’t work well unless placed in the router DMZ.

Netgear WNDR4500

I did try putting Base Station 1 on the DMZ for a small amount of time as a test. Didn’t seem to help. Support asked me to open a list of ports on both base stations, which didn’t make sense to me because it was the same ports on both base stations. Seems to me like that would cause a collision of traffic.
Thanks again for your time and willingness to help.
Dan