Not forwarding caller ID to virtual extension

I have a personal cell phone and have my phone set up on a virtual extension. The one issue that I have is that the caller ID forwards to my phone which I cannot tell when calls originate from my office or it’s just a personal phone call. Is there a way to only show the office main phone number they called forwarded to my virtual extension so I know it’s a business call from my office? I would assume this feature would be a checkbox to “show caller ID of receiving phone line” or something. This would be highly useful as I would use my phone to filter calls knowing it came from the office Ooma.

Thanks!