My side of call drops when dialing certain exchange

I have Comcast cablemodem, with ooma office plugged in to it. Most of the time my calls work great. Occasionally I’ll talk to someone and 15 seconds into the call, they can’t hear me, though I can hear them. While this happens sporadically, it ALWAYS happens when I call a certain exchange. That exchange is owned by a large company and I know they have their own advanced internal telephony systems, etc. I’m trying to use this knowledge to help trouble shoot my problem.

Here is what I’ve tried so far, and then tested by calling the “test exchange” to no avail.

  1. Assigned a static IP to my ooma and then moved ooma into DMZ.
  2. port forwarded all of the required ports to the ooma box.
  3. turned off/on upnp

I run the port scan from the ooma appliance and it shows Denied Ports UDP 53, 123, 514. ***Does anyone know if the port scan actually works? I get the same port scan results no matter whether the box is in DMZ or not, forwarded or not, upnp on or off. I REALLY need to trouble shoot this issue because this exchange that always fails IS MY CLIENT and I need to speak to them. In the meanwhile I always use my cell phone but that doesn’t cut it.

I’m prepared to buy a separate modem if that will solve things. ***Does anyone think that will resolve? If I do, must I buy the separate modem as well, or is it ok to just turn my comcast modem into bridge mode and use it for the modem?

Any insight greatly appreciated!

What model modem do you have?

Hi -

It’s a cicsco, device xb3, model dpc3941t. I had another model but replaced it with this one to see if this resolved the problem. My biz associate uses this model and has no issue. -thank you

I seen people report having issues when using modem with built in voice components.
I’d get a Motorola modem and a router from Costco instead of using these modem/combo units (especially with built in cable digital voice components).