Call times in Call log are off

Hello all:

Is there a way to make the call times in the Ooma call log correct? I’ve changed my Time Zone to EST, but the time is 3 hours off for all calls. I know I can add 3 hours to each call, but was hoping there was a setting somewhere that would correct this based on my location.

Thanks!

Time Option: https://my.ooma.com/system
Did you save and wait for 5 to 10 minutes? Perhaps, power cycle your Ooma?